Информация
Услуги
  • Внедрение
  • Настройка
  • Поддержка
  • Ремонт
Контакты
Оплата
Новости
Доставка
Загрузки
Форум
Настройка
    info@proxmox.su
    +7 (495) 320-70-49
    Заказать звонок
    Аспро: ЛайтШоп
    Войти
    0 Сравнение
    0 Избранное
    0 Корзина
    Аспро: ЛайтШоп
    Войти
    0 Сравнение
    0 Избранное
    0 Корзина
    Аспро: ЛайтШоп
    Телефоны
    +7 (495) 320-70-49
    Заказать звонок
    0
    0
    0
    Аспро: ЛайтШоп
    • +7 (495) 320-70-49
      • Назад
      • Телефоны
      • +7 (495) 320-70-49
      • Заказать звонок
    • info@proxmox.su
    • Москва, Бакунинская улица, 69с1
    • Пн-Пт: 09-00 до 18-00
      Сб-Вс: выходной
    • 0 Сравнение
    • 0 Избранное
    • 0 Корзина
    Главная
    Форум
    Proxmox Виртуальная Среда
    Регистрация аккаунта pvenode acme завершается с ошибкой "Разрешается только один экземпляр Term::ReadLine::Gnu".

    Форумы: Proxmox Виртуальная Среда, Proxmox Backup Server, Proxmox Mail Gateway, Proxmox Datacenter Manager
    Поиск  Пользователи  Правила  Войти
    Страницы: 1
    RSS
    Регистрация аккаунта pvenode acme завершается с ошибкой "Разрешается только один экземпляр Term::ReadLine::Gnu"., Proxmox Виртуальная Среда
     
    Daniel Drucker
    Guest
    #1
    0
    19.08.2025 17:42:00
    В Proxmox 9.0.5:  
    Код: root@oats1:~# pvenode acme account register default ddrucker@mclean.harvard.edu  
    Доступные эндпоинты каталога:  
    0) Let's Encrypt V2 (https://acme-v02.api.letsencrypt.org/directory)  
    1) Let's Encrypt V2 Staging (https://acme-staging-v02.api.letsencrypt.org/directory)  
    2) Пользовательский  
    Выберите вариант: 2  
    Введите пользовательский URL: https://acme.sectigo.com/v2/InCommonECCOV  

    Пытаемся получить Условия обслуживания с 'https://acme.sectigo.com/v2/InCommonECCOV'...  
    Условия обслуживания: https://www.sectigo.com/uploads/files/Certificate-Subscriber-Agreement-2.7-click.pdf  
    Допускается только один экземпляр Term::ReadLine::Gnu. в файле /usr/share/perl5/PVE/CLI/pvenode.pm строка 140.  
    root@oats1:~#
     
     
     
    shapez0r
    Guest
    #2
    0
    08.09.2025 19:09:00
    Теперь приходила ошибка 'unauthorized' от ACME, даже когда использовался параметр --directory. Замечание: в нашем случае это eab-kid и eab-hmac-key с --directory https://acme.enterprise.sectigo.com. В общем, просто установил certbot и использовал его с pvenode cert set /path/to/cert/fullchain.pem /path/to/privatekey/privkey.pem --force --restart — у меня сработало.

    Кстати, изначальный заказ сертификата через pvenode acme, кажется, не учитывает настройки прокси Proxmox, поэтому нужно сначала сделать экспорт HTTPS_PROXY=. Также кнопка в GUI игнорирует прокси, так что это всё равно не настоящая автоматизация acme.

    В certbot можно сделать так:
    Code:
    cat << EOF > /etc/systemd/system/certbot.service.d/override.conf
    [Service]
    Environment="http_proxy=http://proxy:port"
    Environment="https_proxy=http://proxy:port"
    Environment="no_proxy="127.0.0.1,localhost,.."
    EOF
     
     
     
    ericson2110
    Guest
    #3
    0
    13.09.2025 09:50:00
    Столкнулся с той же проблемой, что и Даниэль. Это меняет поведение, но приводит, по крайней мере, к другой ошибке:  
    Код: Генерация ключа аккаунта ACME...  
    Регистрация аккаунта ACME...  

    ОШИБКА ЗАДАЧИ: Регистрация не удалась: Ошибка: GET запрос к https://acme-staging-v02.api.letsencrypt.org/directory 'acme-ACCOUNT-NAME'-locked команда превысила время ожидания — прерывание.  

    URL разрешается и доступен на хосте pve:  
    Код: root@pve01:~# curl https://acme-staging-v02.api.letsencrypt.org/directory  
    {  
     "9Vi9z8_KohI": "https://community.letsencrypt.org/t/adding-random-entries-to-the-directory/33417",  
     "keyChange": "https://acme-staging-v02.api.letsencrypt.org/acme/key-change",  
     "meta": {  
       "caaIdentities": [
         "letsencrypt.org"  
       ],  
       "profiles": {  
         "classic": "https://letsencrypt.org/docs/profiles#classic",  
         "shortlived": "https://letsencrypt.org/docs/profiles#shortlived (пока не доступен для общего пользования)",  
         "tlsserver": "https://letsencrypt.org/docs/profiles#tlsserver"  
       },  
       "termsOfService": "https://letsencrypt.org/documents/LE-SA-v1.5-February-24-2025.pdf",  
       "website": "https://letsencrypt.org/docs/staging-environment/"  
     },  
     "newAccount": "https://acme-staging-v02.api.letsencrypt.org/acme/new-acct",  
     "newNonce": "https://acme-staging-v02.api.letsencrypt.org/acme/new-nonce",  
     "newOrder": "https://acme-staging-v02.api.letsencrypt.org/acme/new-order",  
     "renewalInfo": "https://acme-staging-v02.api.letsencrypt.org/acme/renewal-info",  
     "revokeCert": "https://acme-staging-v02.api.letsencrypt.org/acme/revoke-cert"  
    }
     
     
     
    aballi1
    Guest
    #4
    0
    15.09.2025 13:33:00
    Не уверен, что это та же ошибка, но я её решил. У меня была такая же ошибка: Only one Term::ReadLine::Gnu instance is allowed. И ещё были другие проблемы. Например, я не мог зарегистрировать подписку Proxmox. После установки Proxmox на чистый Debian 13 через APT я пропустил шаг с autoremove. Оставил модули Perl 5.36. На другом сервере я их переустановил, снова добавив в apt источники Debian bookworm. И в конце у меня была ошибка в настройке IPv6. После того как я исправил всё это — ошибки исчезли.
     
     
     
    pingoop
    Guest
    #5
    0
    17.09.2025 17:33:00
    Только что обновились до PVE 9.0.10 на всех хостах (частично потому, что процесс с сертификатами и в предыдущей версии не работал), и теперь у нас та же самая ошибка. Использование переключателя --directory меняет ошибку на «неавторизован», как и упоминал @shapez0r. Завтра попробуем обход с помощью certbot напрямую.
     
     
     
    pingoop
    Guest
    #6
    0
    18.09.2025 14:46:00
    Могу подтвердить, что запрос через certbot, а затем обход с помощью pvenode cert set прошли успешно.
     
     
     
    ericson2110
    Guest
    #7
    0
    20.09.2025 13:55:00
    Отлично слышать! Тем не менее, хотелось бы вернуть функционал native обратно.
     
     
     
    victorclaessen
    Guest
    #8
    0
    25.09.2025 14:23:00
    У меня такая же проблема. Обходной путь с указанием директории в командной строке приводит к ошибке на этапе key id, так же, как у shapez0r и pingoop выше. Код:  
    root@<SNIP>:~# pvenode acme account register harica victor.claessen@hfml-felix.nl --directory https://acme-v02.harica.gr/acme/<SNIP>/directory

    Пытаюсь получить Условия использования с 'https://acme-v02.harica.gr/acme/<SNIP>/directory'...  
    Условия использования: https://repo.harica.gr/documents/SA-ToU.pdf  
    Вы соглашаетесь с вышеуказанными условиями? [y|N]: y
    CA требует внешнюю связку аккаунта.  
    Вы должны были получить key id и ключ от вашего CA.  
    Разрешён только один экземпляр Term::ReadLine::Gnu. в /usr/share/perl5/PVE/CLI/pvenode.pm строка 161.
     
     
     
    victorclaessen
    Guest
    #9
    0
    25.09.2025 14:31:00
    Грязный хак:  
    * закомментируйте (то есть добавьте # в начале) все строки, содержащие код: my $term = Term::ReadLine->new('pvenode');  
    * добавьте эту строку кода: my $term = Term::ReadLine->new('pvenode'); на 98-й строке (сразу после этой строки: my ($param) = @_; )  

    И вот команда pvenode acme account register внезапно начинает работать.
     
     
     
    Bab55z
    Guest
    #10
    0
    25.09.2025 18:39:00
    Этот способ работает, спасибо.
     
     
     
    YaZoal
    Guest
    #11
    0
    26.11.2025 11:15:00
    Ссылка на отчет о баге в Bugzilla и патч в git: https://bugzilla.proxmox.com/show_bug.cgi?id=6873 https://git.proxmox.com/?p=pve-manager.git;a=commit;h=f782c568ce3fcc63d60239b21304886a734e9146
     
     
     
    Страницы: 1
    Читают тему
    +7 (495) 320-70-49
    info@proxmox.su

    Конфиденциальность Оферта
    © 2026 Proxmox.su
    Главная Каталог 0 Корзина 0 Избранные Кабинет 0 Сравнение Акции Контакты Услуги Бренды Отзывы Компания Лицензии Документы Реквизиты Поиск Блог Обзоры